PHYSX NEWS PHYSX SDK
PROJECTS TABLE
GPU PHYSX
GAMES INFO
PHYSX
ARTICLES
PHYSX WIKI FORUM
РУССКИЙ ENGLISH


:: Back to news index ::

Hybrid PhysX: 197.xx drivers and PhysX performance fix

with 46 comments

Recent PhysX drivers 9.10.0222 and 197.xx NV GPU drivers are mostly incompatible with 1.02 GenL Mod for Hybrid PhysX systems (witch hunt, another round) – using this drivers set will results in Metro 2033 crashes, abnormal FluidMark behaviour and performance problems in other PhysX games.

However, user Containforum, known for his Hybrid PhysX installation guide and Catalyst 10.2 extended display fix, has come out with a solution – he created a “patch”, that resolves  performance problems (at least for FluidMark) and allows you to use Hybrid PhysX without necessity to extend display.

Update: You can download containforum’s fix 1.02 here (25 mb). GenL mod must be applied firstly.

Update #2: comment from GenL

Result can’t be called a “patch” anyway. This package contains several unmodified (unpatched) files from PhysX SS v9.09.1112 and v9.10.0129. While this can’t be a proper solution for newer versions of PhysX SS, i’m surprised it worked for people

Update #3: Extended display fix only.

UPDATE: Hybrid PhysX mod 1.03 released – with timebomb fix and lastest drivers support.

It’s recommended to use it with 196.34 drivers and latest PhysX System Software.

Please use this post or comment at youtube to report if this fix is working with other GPU PhysX games, or any problems you will encounter.

Written by Zogrim

March 29th, 2010 at 9:30 am

Posted in Hybrid PhysX

Tagged with , ,

46 Responses to 'Hybrid PhysX: 197.xx drivers and PhysX performance fix'

Subscribe to comments with RSS

  1. Good effort on trying to solve the problem, but the result can’t be called a “patch” anyway.
    This package contains several unmodified (unpatched) files from PhysX SS v9.09.1112 and v9.10.0129. While this can’t be a proper solution for newer versions of PhysX SS, i’m surprised it worked for people.

    Still nobody has any clear answer on “what causing this problem – new driver or new PhysX SS?”. Because some people reported that 9.10.0222 package is working with 196.34 driver, you know.

    I’m afraid i’d have to buy an nvidia card and Windows 7 for myself just to be able to find and solve this problem… Until then i won’t be able to update the mod properly, i think.

    Still, i wouldn’t recommend people to use methods like here just to have the latest digit in “About” PhysX dialog. For testing – maybe, but not for everyday use.

      

    (QUOTE)

    GenL

    30 Mar 10 at 7:12 pm

  2. Yes… This mod doesn`t work with Metro 2033. I tried reinstall physx (this deleting mod) and/// Metro working normal (my 9800GT load 100%)

      

    (QUOTE)

    Alexey

    30 Mar 10 at 7:51 pm

  3. in mode 167.34 + Genl`s mod+ latest physx Metro work properly (without this bughttp://www.youtube.com/watch?v=2TOXo98l4aU) but.. gpu on my 9800GT load max at 30%

      

    (QUOTE)

    Alexey

    30 Mar 10 at 8:10 pm

  4. @ ContainForum

    It is in: C:\Program Files (x86)\NVIDIA Corporation\PhysX, the same location the installer points to.

      

    (QUOTE)

    svol

    30 Mar 10 at 9:13 pm

  5. Hmm… Maybe try 197.13 drivers? I’ll be doing a little more tests and research on the drivers. Although my solution does seem to work for now, like GenL stated; it isn’t a solid fix. However I’ll try my best to find a better solution.

    For now it is atleast a solution to having to use extended display for some drivers.

      

    (QUOTE)

    ContainForum

    30 Mar 10 at 9:23 pm

  6. @GenL

    Maybe we should meet each other @ RCE in OFFTOPIC

    Let write a physx wrapper ;-) )

      

    (QUOTE)

    nvidia_is_cheating

    30 Mar 10 at 9:44 pm

  7. @nvidia_is_cheating
    I’m not really into coding things, and i’m sure even talented people would need at least months to write a thing as complex as PhysX wrapper… Of course if you meant wrapper for non-nvidia hardware.

      

    (QUOTE)

    GenL

    30 Mar 10 at 9:54 pm

  8. Hey GenL.

    Just some info I thaught I should share. I was observing the drivers and I notice that the files in C:\Program Files\NVIDIA Corporation have no effect on the situation at all.

    However the PhysXcore.dll files seem to be causing the issue with 197.XX located in C:\Program Files (x86)\NVIDIA Corporation\PhysX\Engine

    When those files are replaced it seems to work, but those same files work when using 196.XX drivers :S

    I attempted to slightly modify the PhysXcore.dll files hoping that it’s another DLL located in the Windows folder hen it detects the newest version of PhysX, however still not working.

    I have it narrowed down to a possible combination of a file from Nvidia from the Windows folder and the PhysX system files.

      

    (QUOTE)

    ContainForum

    30 Mar 10 at 10:56 pm

  9. Thanks for info, ContainForum. If they added checks to all these files, i may be able to find them. But i’d still need to get nvidia GPU for this, because plain messaging with testers is not really getting anywhere lately.

      

    (QUOTE)

    GenL

    31 Mar 10 at 12:10 am

  10. Yeah, thats right. Best of luck finding a cheap Nvidia card. :D

    In the mean time I’ll attempt to find exactly which files are causing this.

      

    (QUOTE)

    ContainForum

    31 Mar 10 at 12:30 am

  11. Hey again GenL, so far it seems all hands point towards Nvcuda.dll in System32 and Syswow64.

    I’m still not 100% sure. I’ll keep testing.

      

    (QUOTE)

    ContainForum

    31 Mar 10 at 2:06 am

  12. Hello everyone. Here are the files you need to have onylt he extended display fix with latest PhysX software.

    http://rapidshare.com/files/370927510/Hybrid_PhysX_Extended_Display_Fix.zip

    I reccomend you use 196.34 drivers with the latest PhysX software. For now this seems to be the best option.

      

    (QUOTE)

    ContainForum

    2 Apr 10 at 3:00 am

  13. Ok maybe I am missing something. If I use the 196.21 drivers along with the included Physx in that driver install everything works great. Unfortunatly Mirror’s edge has some slow down and Metro 2033 requires you to use the latest Physx.

    If I install the latest Physx software, install the 1.02 mod and the patch listed here fluidmark states that I am running Physx in software mode. I can confirm this because if Physx is turned on in Batman AA with the latest Physx software my system tanks.

    How do you force Physx 9.10.0222 to work with older drivers and actually get hardware Physx?

      

    (QUOTE)

    Justin Wenderoth

    3 Apr 10 at 11:59 pm

  14. Use 196.34 drivers.

      

    (QUOTE)

    ContainForum

    4 Apr 10 at 3:02 pm

  15. @GenL
    Can you all tell us how your mod works? maybe we can help you. … and you dont have a nvidia card?

      

    (QUOTE)

    drdoom567

    4 Apr 10 at 9:40 pm

  16. Containforum I installed the 196.34 drivers, installed Physx 9.10.0222, installed mod 1.2, and then this patch and all I get is software phsyx. Next steps?

      

    (QUOTE)

    Justin Wenderoth

    5 Apr 10 at 8:58 am

  17. Ok nevermind. I guess enabling Physx in the Nvidia control panel after reinstalling the drivers might help :) . Everything is fine now.

      

    (QUOTE)

    Justin Wenderoth

    5 Apr 10 at 10:26 am

  18. @drdoom567
    What exactly do you mean? My mod modifies a binary code which is responsible to logical check like “is this GPU made by nvidia?”. You can’t really help with anything but testing.
    Yes i don’t have nvidia card. Yet.

      

    (QUOTE)

    GenL

    5 Apr 10 at 6:56 pm

  19. Can someone give me a link to the ContainForum fix 1.01 plx

      

    (QUOTE)

    Oli

    7 Apr 10 at 2:16 am

  20. Oli
    Link

      

    (QUOTE)

    Zogrim

    7 Apr 10 at 10:06 am


Leave a Reply

CAPTCHA Image
Refresh Image
*
Copyright © 2009-2014. PhysXInfo.com | About PhysXInfo.com project | Privacy Policy
PhysX is trademark of NVIDIA Corporation