Pages: 1 2 3 [4]
Print
Author Topic: How to restore PPU support with latest Nvidia Drivers  (Read 107524 times)
Zogrim
Administrator
Hero Member
*****
Posts: 565


Expert Scrounger


View Profile WWW
« Reply #45 on: October 19, 2012, 01:38:53 am »

Quote
It also seems like some software Physx games are running slightly smoother since getting the drivers to work but, it's such small difference it might just be placebo
PPU was able to run even software PhysX games in hardware mode (something that GPU can't do), but the performance difference was negligible (you can't sell hardware with that), and that's why we have PPU games with extra physics effects.
Logged

PhysXInfo.com Team
mohawkade
Jr. Member
**
Posts: 66


Embrace your spark of madness!


View Profile WWW
« Reply #46 on: October 20, 2012, 08:00:43 am »

I personally have no experience with the Dell PPU's and cannot vouch for their quality otherwise. Otherwise, BFG or ASUS PPUs I would have some input on.

Also performance may have to do with your graphics card as well; though I've got 2 GTX 470's, I have PhysX dedicated to my BFG PPU sandwiched between them.

With that setup, Mirror's Edge runs relatively smooth on the PPU.

Though in contrast running Mirror's Edge with a PPU on an old Dell PC with a Single Core and an ATI card still had it's share of Lag, even without PhysX on. So your performance may depend on your other hardware.
Logged

OP: Windows 7 Ultimate 64bit
HD: Intel 80GB Solid State Drive (OS)
      1TB Hard Drive (Game Drive)
CPU: AMD Phenom II X6, 3.2GHz
RAM: 8GB, DDR3-1600
GPU: Nvidia Geforce GTX 470 x2 SLI
Audio: X-Fi Fatal1ty Champion Sound Card
PPU: BFG Ageia PhysX Card
Azrael5
Newbie
*
Posts: 10



View Profile
« Reply #47 on: October 30, 2012, 07:02:22 pm »

here are some tests made by the use of PPU. Note the results when it matches ATI video card:

Logged

Case Thermaltake Mozart PSU OCZ ModXtreme-Pro 700w MainBoard Asrock 4coredual-sata2; Heatsink ZeroTherm Zen120 CPU Core2 Extreme X6800 3,2 Ghz RAM OCZ Platinum DDR400, 2x1 GB GPU Sapphire HD3850 AGP PPU Asus Physx P1 PCI-Express HDD WD Caviar Blue WD5000AAKS Monitor Asus VB175T Sound Logitech Z-5500
mohawkade
Jr. Member
**
Posts: 66


Embrace your spark of madness!


View Profile WWW
« Reply #48 on: June 08, 2015, 03:14:58 am »

Hi Everyone, it's been a long time. I'm giving this forum a bump as I've plugged my old PPU back into my system, with a custom heatsink (since the old one died).

But I've been dabbling around and I made an installer that restores the Ageia PPU drivers on top of current PhysX drivers. I've tested it with a clean install on my system but in order for me to confirm this installer's effectiveness. I'll kindly ask anyone else with a PPU to give it a try. Link can be found below:

https://mega.co.nz/#!tBd3gDoC!r3Pqc7Rk_bzTws6Mfp3_P2nW9sxeZ7qToBV3rcyTRwA

Also considering that next February will be the 10 year anniversary of the release of the PPU, I am starting plans on a sort-of anniversary video.
Logged

OP: Windows 7 Ultimate 64bit
HD: Intel 80GB Solid State Drive (OS)
      1TB Hard Drive (Game Drive)
CPU: AMD Phenom II X6, 3.2GHz
RAM: 8GB, DDR3-1600
GPU: Nvidia Geforce GTX 470 x2 SLI
Audio: X-Fi Fatal1ty Champion Sound Card
PPU: BFG Ageia PhysX Card
joeyshorty2
Newbie
*
Posts: 45


View Profile
« Reply #49 on: June 12, 2015, 02:39:41 am »

I still have the PPU in my HTPC with an AMD card. I'll give it a shot later and let you know how it goes.

Update: Sorry haven't been able to test it yet. I had to move recently and wasn't able to take my HTPC with me temporarily. I will let you know if it worked when I get it back.

Update #2: The Installer works great! Really easy and quick.
Logged
joeyshorty2
Newbie
*
Posts: 45


View Profile
« Reply #50 on: April 18, 2016, 03:28:23 am »

@MohawkADE I was curious. The PPU seems to be working when I do a Start Extended Diagnostics but I don't think the games are. Also,  when I go to the demos they say Software mode and that (..\..\Core\Device\RegistryHardwareSelection.cpp (71) :warning : CUDA not available)

I was curious to if you have any idea what is going on with this.

This only happens after I install newer Physx drivers after 8.09.04  but I have to install after otherwise Mirror's Edge and other physx games will not work.

Could this possibly be from me having an AMD system?
Logged
Pages: 1 2 3 [4]
Print
Jump to: