Pages: [1] 2
Print
Author Topic: [SOLVED] Hybrid PhysX = major game issues + no PhysX?  (Read 16043 times)
Saturn2888
Newbie
*
Posts: 13


View Profile
« on: December 31, 2010, 11:28:23 am »

[EDIT]: With the same two cards I was able to get it to work fine using 1.05ff

Here's what I did after I put my 9800GTX+ in alongside my HD6870 in Windows 7 64-bit.
 1. Installed nVIDIA 260.99
 2. Restarted
 3. Did the 1.04ff x86-64 version patch
 4. Realized this was wrong, installed 258.96
 5. Patched it
 6. Restarted
 7. Found fluidmark was doing PhysX CPU
 8. Renamed all five physx*.dll files for fluidmark
 9. Ran it again, PhysX CPU still
10. Ran BatmanAA, says my hardware not supported for PhysX in the configuring app
11. Everything looked fine, but it was slow as usual
12. Renamed PhysXExtensions.dll, game would not start saying the file is missing
13. Restarted into Safe Mode
14. Installed 1.04ff non-x64 patch
15. Ran "nvsvc Automatic.bat"
16. Ran "PhysX Hardware Enable.bat"
17. Restarted into Windows
18. Ran fluidmark, says PhysX GPU, but there are no objects being flung across
19. Renamed fluidmark  physx*.dll files back
20. Ran fluidmark, says PhysX CPU
21. Ran BatmanAA GotY, got major artifacting even without FSAA and paper is standing still all oddly spaced; hardly any smoke as if PhysX is enabled but turned off

What in the world is going on?
Logged
Zogrim
Administrator
Hero Member
*****
Posts: 564


Expert Scrounger


View Profile WWW
« Reply #1 on: December 31, 2010, 12:43:45 pm »

Saturn2888
Fist of all, make sure you've followed installation instructions. And there should be no problem with 260.99 drivers.

As for FluidMark (I believe, you're using 1.3.1 version ?) you actually need to delete/rename PhysXDevice.dll (in this case FluidMark will use .dll from patched PhysX drivers) in app folder, or just replace PhysXDevice.dll with patched version.
I won't recommend to touch any other PhysX*.dlls, in any games (except for ME, but this is another story) - this won't make any good.

As GenL said "key file for hybrids is PhysXDevice.dll currently". Replacing PhysXDevice is needed for latest FluidMark only (because it is not using PhysX System Software anymore, thanks for driverless 2.8.4 SDK), other GPU PhysX games should work fine.
Logged

PhysXInfo.com Team
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #2 on: January 02, 2011, 01:24:19 am »

Sorry I haven't replied. I never got an e-mail notification about this even though I'm subscribed.

If I only make it so that one DLL is gone, it's as normal, PhysX CPU. If I make all of them go away, then I get PhysX GPU, but nothing rendering. See the attached file.
Logged
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #3 on: January 02, 2011, 01:35:20 am »

Installed 260.99 again, same deal there. I don't know what's going on, but it's a kernel panic or something happening. I see that thing in the bottom right when I first open FluidMark. I notice that there are objects rendering, the nVIDIA driver shows that kernel thingy, then it refreshes the screen and the balls are gone as in the picture I attached the last post.

Print Screen doesn't capture it for some reason.

PhysXCore.dll and PhysXDevice.dll are the ones I have to rename for this to show PhysX GPU.

I'm starting to think, because of this kernel issue, it has something to do with my motherboard or some setting I've enabled. I just RMA'd this board before putting in that 9800GTX+, and while Crossfire worked on my previous one back when had two ATi GPUs, I haven't tested it since. There may be some BIOS setting I'm not configuring. It's the ASUS Maximus II Formula.
Logged
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #4 on: January 02, 2011, 01:49:03 am »

Finally got a picture
Logged
Zogrim
Administrator
Hero Member
*****
Posts: 564


Expert Scrounger


View Profile WWW
« Reply #5 on: January 02, 2011, 09:43:29 am »

Saturn2888
Apart from FluidMark, how other GPU PhysX applications are running ? Problems too ?
3d Mark Vantage ? Dark Void PhysX benchmark ? Cryostasis demo ? etc

Quote
it has something to do with my motherboard or some setting I've enabled
Also, I've recommend you to dublicate your question here. There are some actual Hybrid users, and I have NV + NV setup, thus might be not a huge help here.
Logged

PhysXInfo.com Team
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #6 on: January 02, 2011, 12:09:41 pm »

Currently just Batman and Fluidmark. I know it doesn't work in Batman either.
Logged
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #7 on: March 25, 2011, 11:41:31 am »

What are the drivers that work for you both the nVIDIA and the PhysX combinations? I will use anything right now so long as it works. I just wanna beat Batman and never deal with nVIDIA again Sad.
Logged
Zogrim
Administrator
Hero Member
*****
Posts: 564


Expert Scrounger


View Profile WWW
« Reply #8 on: March 25, 2011, 11:57:54 am »

What are the drivers that work for you both the nVIDIA and the PhysX combinations?
Try out 257.15
They even will work properly without Hybrid PhysX mod and stuff (Link)
Logged

PhysXInfo.com Team
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #9 on: March 25, 2011, 01:00:47 pm »

I actually tried those two. What happens is it's working, then the nVIDIA driver spazzes out and PhysX is off because the driver had to recover. Sometimes this is a bluescreen. It happened within seconds of starting a PhysX application.
Logged
Zogrim
Administrator
Hero Member
*****
Posts: 564


Expert Scrounger


View Profile WWW
« Reply #10 on: March 25, 2011, 04:46:42 pm »

I actually tried those two. What happens is it's working, then the nVIDIA driver spazzes out and PhysX is off because the driver had to recover. Sometimes this is a bluescreen. It happened within seconds of starting a PhysX application.

Than I recommend you to duplicate this question at NGOHQ forums (Link), I'm not a huge help here, since I own NV + NV PhysX system.
Logged

PhysXInfo.com Team
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #11 on: March 25, 2011, 04:53:31 pm »

Ah yeah, I remember now Tongue. You've been really helpful though. Do you know where I'd wanna ask at NGOHQ?
Logged
Zogrim
Administrator
Hero Member
*****
Posts: 564


Expert Scrounger


View Profile WWW
« Reply #12 on: March 25, 2011, 07:50:44 pm »

Ah yeah, I remember now Tongue. You've been really helpful though. Do you know where I'd wanna ask at NGOHQ?

There is one big thread, I've provided link in previous post
http://www.ngohq.com/graphic-cards/17706-hybrid-physx-mod-v1-03-v1-04ff-123.html
Logged

PhysXInfo.com Team
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #13 on: March 26, 2011, 01:27:50 am »

Ah sorry, didn't notice that (Link) was a link. Thank you so much!
Logged
Saturn2888
Newbie
*
Posts: 13


View Profile
« Reply #14 on: January 01, 2012, 03:32:02 pm »

I waited long enough for this to work and guess what? It does! Cheesy.

I noticed 1.05ff was released and tried it out just tonight. Since I already had the latest PhysX drivers installed, all I needed was to pull that old 9800GTX+ outta another rig I don't use anyway.

Not forgetting the two 6-pin power connectors, I put it in my main rig, installed the drivers, then patched them with 1.05ff. All of this without restarting, I fired up Batman Arkham Asylum and what do you know, it works perfectly!

Very simple. I highly recommend this for anyone wanting to get the benefits of PhysX in newer games.

Thanks to everyone here who'd tried to help me in the past!
Logged
Pages: [1] 2
Print
Jump to: